加入我们的< >

Wordpress中的Gutenberg编辑器对我的网站意味着什么?

如果你是一个想要从4.9.8升级到5.0的Wordpress用户,你可能会想要阅读这篇文章。当然,除非你喜欢被逮个正着。

我不想太夸张,但我想告诉你最近你的Wordpress网站发生了什么。这有点专业,但我会尽力避免它变成疯狂的机器人语言。

首先要注意的是,Wordpress发布的5.0版本包含了一个名为Gutenberg的新编辑器。如果你从版本5开始。X,你可以走了。你只需要学习一个新系统,叫做

然而,如果你已经在使用Wordpress——除非你做好了适当的准备——迁移到5.0版本(Gutenberg)不太可能是好消息,因为它改变了Wordpress的工作方式,导致意想不到的中断和你的内容。

第一个你要做的是安装经典的编辑器插件,它会返回到您常用的处理遗留内容的编辑器。这个插件将把你的整个内容作为一个块,直到你转换它。

convert-to-blocks


一线希望:古腾堡是超现代的。

partial-blocks-list

它的特色是允许页面结构编辑的工具。非常强大。事实上,它是如此强大,以至于我们希望它能打破之前的网站。这样做的原因是这个编辑器与许多web开发人员用来创建侧边栏和大多数网站中发现的其他布局组件的工具并不完全兼容。

页面构建器和格式化工具等高级定制字段(ACF有一个更新-阅读他们的博客关于这个主题)是最不利的影响。这些工具可以在几乎所有的WordPress网站中找到,这就是为什么你的WordPress网站——以及几乎所有其他WordPress网站——可能会受到如此大的影响。

当User更新到5.0时(这是用于安全与稳定原因)给新的编辑,在他们编辑之前什么都不会发生。然后事情就会开始破裂。也许不会崩溃,但肯定会做出意想不到的举动。

例如,列表显示为一组块。段落的处理是类似的。用户可以安装任何他们想要的块类型,不管他们的UX知识水平如何。有如此多的块,古登堡使他们搜索。


不那么光明的一面,即时危机。

这个编辑器已经非常迅速地加入到Wordpress核心中,这让开发者社区(和客户端)有些措手不及。没有Wordpress BG(在Gutenberg之前)和Wordpress AG之间的升级或迁移路径(在古腾堡之后),事情可能会破裂。

我们希望避免您的网站崩溃。因此,在准备好进行转换之前,请不要更新到5.0版本。您可能需要重新构建站点或将其迁移到另一个平台。这对机构来说是个好消息。这对客户来说可不太好。

我们希望通过帮助你准备好你的Wordpress站点来正确地使用古腾堡堡(并避免崩溃),或者帮助你切换到其他伟大的平台,来领先于危机HubSpot的SquareSpace.这样,你就有了最现代化的网站,避免了网站崩溃的风险和失去业务的可能性。

gutenberg-editor-prompt

原始的古腾堡插件提示符(如果没有准备好,请自行更新)。

迁移到Gutenberg的一个问题是它没有很好的文档记录(作为一个Wordpress用户,你可能已经习惯了)。因此,如果您选择更新到Gutenberg,要知道与其他选项相比,部署可能会感觉有点慢……虽然大多数开发技术和策略仍然有效,但对于开发人员和用户来说,也有许多新的学习内容。

在我结束之前,我想告诉你一个小秘密,KAYAK团队发布了一个β称为流,这是一个古腾堡友好的高级Wordpress主题,专门为客户产生和咨询业务模式设计。

与此同时,让我们努力你的下一个网站有史以来最强大的。请随时问我有什么选择。我会尽力解决的。

网站设计的潜在客户

主题:营销策略

Baidu
map